$re = '/message:\s(?<METADATA_ERROR>[^\\\\\n]+)/m';
$str = 'message: org.springframework.jdbc.UncategorizedSQLException: CallableStatementCallback; uncategorized SQLException for SQL <{call XYZ_API.PROCESS_EVENT(?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)}>; SQL state <16000>; error code <20011>; ORA-00060: deadlock detected while waiting for resource\\nORA-06512: at "ABC_OWNER.XYZ_API", line 5133\\nORA-06512: at "ABC_OWNER.XYZ_API", line 2001\\nORA-06512: at "ABC_OWNER.XYZ_API", line 6829\\nORA-06512: at line 1\\n; nested exception is java.sql.SQLException: ORA-00060: deadlock detected while waiting for resource\\nORA-06512: at "ABC_OWNER.XYZ_API", line 5133\\nORA-06512: at "ABC_OWNER.XYZ_API", line 2001\\nORA-06512: at "ABC_OWNER.XYZ_API", line 6829\\nORA-06512: at line 1\\n\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);