$re = '/(?m)^ {4}/';
$str = ' try (EchoClient echoClient = EchoClient.create()) {
EchoRequest request = EchoRequest.newBuilder().build();
EchoResponse response = echoClient.echo(request);
}';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;