import Foundation
let pattern = #"(?m)^ {4}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
try (EchoClient echoClient = EchoClient.create()) {
EchoRequest request = EchoRequest.newBuilder().build();
EchoResponse response = echoClient.echo(request);
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)