using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<func>latest|diff|avg|median|total|rollingmedian|rollingavg)\((?<par>[^(),]*),(?<uom>[^(),]*)(?:,(?<sp>[^()]*|))?\))|((?<func1>diffdays)\((?<par1>[^(),]*)(?:,(?<sp1>[^()]*|))?\))+";
string input = @"rollingmedian( ecoli, orgs/100mL, [tat10, tat11] ) + latest(ecoli,) + diffdays(ecoli)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}