import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<func>latest|diff|avg|median|total|rollingmedian|rollingavg)\\((?<par>[^(),]*),(?<uom>[^(),]*)(?:,(?<sp>[^()]*|))?\\))|((?<func1>diffdays)\\((?<par1>[^(),]*)(?:,(?<sp1>[^()]*|))?\\))+";
final String string = "rollingmedian( ecoli, orgs/100mL, [tat10, tat11] ) + latest(ecoli,) + diffdays(ecoli)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}