re = /((?<func>latest|diff|avg|median|total|rollingmedian|rollingavg)\((?<par>[^(),]*),(?<uom>[^(),]*)(?:,(?<sp>[^()]*|))?\))|((?<func1>diffdays)\((?<par1>[^(),]*)(?:,(?<sp1>[^()]*|))?\))+/
str = 'rollingmedian( ecoli, orgs/100mL, [tat10, tat11] ) + latest(ecoli,) + diffdays(ecoli)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end