import re
regex = re.compile(r"((?<func>latest|diff|avg|median|total|rollingmedian|rollingavg)\((?<par>[^(),]*),(?<uom>[^(),]*)(?:,(?<sp>[^()]*|))?\))|((?<func1>diffdays)\((?<par1>[^(),]*)(?:,(?<sp1>[^()]*|))?\))+")
test_str = "rollingmedian( ecoli, orgs/100mL, [tat10, tat11] ) + latest(ecoli,) + diffdays(ecoli)"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")