#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bconfig\.([\w.]+)(?![(\w])"
Local $sString = "config.hello.world should match hello.world" & @CRLF & _
"config.hello should match hello" & @CRLF & _
"config.hello.world( should match hello" & @CRLF & _
"config.hello.world*10 should match hello.world"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")