$re = '/\bconfig\.([\w.]+)(?![(\w])/m';
$str = 'config.hello.world should match hello.world
config.hello should match hello
config.hello.world( should match hello
config.hello.world*10 should match hello.world';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);