import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bconfig\\.([\\w.]+)(?![(\\w])";
final String string = "config.hello.world should match hello.world\n"
+ "config.hello should match hello\n"
+ "config.hello.world( should match hello\n"
+ "config.hello.world*10 should match hello.world";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}