using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bconfig\.([\w.]+)(?![(\w])";
string input = @"config.hello.world should match hello.world
config.hello should match hello
config.hello.world( should match hello
config.hello.world*10 should match hello.world";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}