re = /\bconfig\.([\w.]+)(?![(\w])/m
str = 'config.hello.world should match hello.world
config.hello should match hello
config.hello.world( should match hello
config.hello.world*10 should match hello.world'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end