using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(www.ibm.com\/products\/(clinical-development.*|digital-health-pass.*|health-insights.*|marketscan-inpatient-outpatient-view*|marketscan-research-databases.*|marketscan-treatment-pathways.*))|(www.ibm.com\/watson-health\/solutions\/health-human-services-analytic.*)";
string input = @"www.ibm.com/products/digital-health-pass
www.ibm.com/products/health-insights/
www.ibm.com/watson-health/solutions/health-human-services-analytics
www.ibm.com/products/marketscan-research-databases
www.ibm.com/products/marketscan-treatment-pathways
www.ibm.com/products/marketscan-inpatient-outpatient-view""
www.ibm.com/products/clinical-development
www.ibm.com/products/clinical-development/features
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}