use strict;
my $str = 'www.ibm.com/products/digital-health-pass
www.ibm.com/products/health-insights/
www.ibm.com/watson-health/solutions/health-human-services-analytics
www.ibm.com/products/marketscan-research-databases
www.ibm.com/products/marketscan-treatment-pathways
www.ibm.com/products/marketscan-inpatient-outpatient-view"
www.ibm.com/products/clinical-development
www.ibm.com/products/clinical-development/features
';
my $regex = qr/^(www.ibm.com\/products\/(clinical-development.*|digital-health-pass.*|health-insights.*|marketscan-inpatient-outpatient-view*|marketscan-research-databases.*|marketscan-treatment-pathways.*))|(www.ibm.com\/watson-health\/solutions\/health-human-services-analytic.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}