// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(www.ibm.com\/products\/(clinical-development.*|digital-health-pass.*|health-insights.*|marketscan-inpatient-outpatient-view*|marketscan-research-databases.*|marketscan-treatment-pathways.*))|(www.ibm.com\/watson-health\/solutions\/health-human-services-analytic.*)").unwrap();
let string = "www.ibm.com/products/digital-health-pass
www.ibm.com/products/health-insights/
www.ibm.com/watson-health/solutions/health-human-services-analytics
www.ibm.com/products/marketscan-research-databases
www.ibm.com/products/marketscan-treatment-pathways
www.ibm.com/products/marketscan-inpatient-outpatient-view\"
www.ibm.com/products/clinical-development
www.ibm.com/products/clinical-development/features
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}