$re = '/^(www.ibm.com\/products\/(clinical-development.*|digital-health-pass.*|health-insights.*|marketscan-inpatient-outpatient-view*|marketscan-research-databases.*|marketscan-treatment-pathways.*))|(www.ibm.com\/watson-health\/solutions\/health-human-services-analytic.*)/m';
$str = 'www.ibm.com/products/digital-health-pass
www.ibm.com/products/health-insights/
www.ibm.com/watson-health/solutions/health-human-services-analytics
www.ibm.com/products/marketscan-research-databases
www.ibm.com/products/marketscan-treatment-pathways
www.ibm.com/products/marketscan-inpatient-outpatient-view"
www.ibm.com/products/clinical-development
www.ibm.com/products/clinical-development/features
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);