import Foundation
let pattern = #"^(www.ibm.com\/products\/(clinical-development.*|digital-health-pass.*|health-insights.*|marketscan-inpatient-outpatient-view*|marketscan-research-databases.*|marketscan-treatment-pathways.*))|(www.ibm.com\/watson-health\/solutions\/health-human-services-analytic.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
www.ibm.com/products/digital-health-pass
www.ibm.com/products/health-insights/
www.ibm.com/watson-health/solutions/health-human-services-analytics
www.ibm.com/products/marketscan-research-databases
www.ibm.com/products/marketscan-treatment-pathways
www.ibm.com/products/marketscan-inpatient-outpatient-view"
www.ibm.com/products/clinical-development
www.ibm.com/products/clinical-development/features
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)