using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|\t)
(
[^\t\n]+(?=(?:\t|\n[^ ]))
|
[^\t\n]+(?=(?:\t|\n([ ]+)))
)
#(|[ ]{20})#(?![ ]{3,})
#|
#[^\t]+?(?=(?:\n)([ ]+)"")
";
string substitution = @"/$2/";
string input = @"База Базовая добыча (вЯк 8) 42370
Бурение well_obj1_1_prod (вЯк 8) 42370
Бурение well_obj1_1_inj (вЯк 8) 42430
""";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Singleline | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}