use strict;
my $str = 'База Базовая добыча (вЯк 8) 42370
Бурение well_obj1_1_prod (вЯк 8) 42370
Бурение well_obj1_1_inj (вЯк 8) 42430
"';
my $regex = qr/(?:^|\t)
(
[^\t\n]+(?=(?:\t|\n[^ ]))
|
[^\t\n]+(?=(?:\t|\n([ ]+)))
)
#(|[ ]{20})#(?![ ]{3,})
#|
#[^\t]+?(?=(?:\n)([ ]+)")
/xsmp;
my $subst = '/$2/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";