$re = '/(?:^|\t)
(
[^\t\n]+(?=(?:\t|\n[^ ]))
|
[^\t\n]+(?=(?:\t|\n([ ]+)))
)
#(|[ ]{20})#(?![ ]{3,})
#|
#[^\t]+?(?=(?:\n)([ ]+)")
/xsm';
$str = 'База Базовая добыча (вЯк 8) 42370
Бурение well_obj1_1_prod (вЯк 8) 42370
Бурение well_obj1_1_inj (вЯк 8) 42430
"';
$subst = "/$2/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;