package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https?:\/\/(?:www\.)?xkcd\.com\/([0-9]+)`)
var str = `https://www.xkcd.com/927
http://www.xkcd.com/927
https://xkcd.com/927
http://xkcd.com/927`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}