import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/(?:www\\.)?xkcd\\.com\\/([0-9]+)";
final String string = "https://www.xkcd.com/927\n"
+ "http://www.xkcd.com/927\n"
+ "https://xkcd.com/927\n"
+ "http://xkcd.com/927";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}