re = /https?:\/\/(?:www\.)?xkcd\.com\/([0-9]+)/
str = 'https://www.xkcd.com/927
http://www.xkcd.com/927
https://xkcd.com/927
http://xkcd.com/927'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end