// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"https?:\/\/(?:www\.)?xkcd\.com\/([0-9]+)").unwrap();
let string = "https://www.xkcd.com/927
http://www.xkcd.com/927
https://xkcd.com/927
http://xkcd.com/927";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}