const regex = new RegExp('https?:\\/\\/(?:www\\.)?xkcd\\.com\\/([0-9]+)', 'g')
const str = `https://www.xkcd.com/927
http://www.xkcd.com/927
https://xkcd.com/927
http://xkcd.com/927`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}