package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(Ex(?:PRD|QAT|TST))(.*)`)
var str = `ExPRD(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=whatever.com)(PORT=0000))(ADDRESS=(PROTOCOL=TCP)(HOST=whatever2.com)(PORT=0000))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=ExPRD)))
ExQAT(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=whatever.com)(PORT=0000))(ADDRESS=(PROTOCOL=TCP)(HOST=whatever2.com)(PORT=0000))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=ExQAT)))
ExTST(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=whatever.com)(PORT=0000))(ADDRESS=(PROTOCOL=TCP)(HOST=whatever2.com)(PORT=0000))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=ExTST)))`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}