# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(Ex(?:PRD|QAT|TST))(.*)"
test_str = ("ExPRD(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=whatever.com)(PORT=0000))(ADDRESS=(PROTOCOL=TCP)(HOST=whatever2.com)(PORT=0000))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=ExPRD)))\n"
"ExQAT(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=whatever.com)(PORT=0000))(ADDRESS=(PROTOCOL=TCP)(HOST=whatever2.com)(PORT=0000))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=ExQAT)))\n"
"ExTST(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=whatever.com)(PORT=0000))(ADDRESS=(PROTOCOL=TCP)(HOST=whatever2.com)(PORT=0000))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=ExTST)))")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.