import Foundation
let pattern = #"^(Ex(?:PRD|QAT|TST))(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ExPRD(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=whatever.com)(PORT=0000))(ADDRESS=(PROTOCOL=TCP)(HOST=whatever2.com)(PORT=0000))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=ExPRD)))
ExQAT(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=whatever.com)(PORT=0000))(ADDRESS=(PROTOCOL=TCP)(HOST=whatever2.com)(PORT=0000))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=ExQAT)))
ExTST(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=whatever.com)(PORT=0000))(ADDRESS=(PROTOCOL=TCP)(HOST=whatever2.com)(PORT=0000))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=ExTST)))
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)