$re = '/^(Ex(?:PRD|QAT|TST))(.*)/m';
$str = 'ExPRD(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=whatever.com)(PORT=0000))(ADDRESS=(PROTOCOL=TCP)(HOST=whatever2.com)(PORT=0000))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=ExPRD)))
ExQAT(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=whatever.com)(PORT=0000))(ADDRESS=(PROTOCOL=TCP)(HOST=whatever2.com)(PORT=0000))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=ExQAT)))
ExTST(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=whatever.com)(PORT=0000))(ADDRESS=(PROTOCOL=TCP)(HOST=whatever2.com)(PORT=0000))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=ExTST)))';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;