// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(Ex(?:PRD|QAT|TST))(.*)").unwrap();
let string = "ExPRD(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=whatever.com)(PORT=0000))(ADDRESS=(PROTOCOL=TCP)(HOST=whatever2.com)(PORT=0000))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=ExPRD)))
ExQAT(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=whatever.com)(PORT=0000))(ADDRESS=(PROTOCOL=TCP)(HOST=whatever2.com)(PORT=0000))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=ExQAT)))
ExTST(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=whatever.com)(PORT=0000))(ADDRESS=(PROTOCOL=TCP)(HOST=whatever2.com)(PORT=0000))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=ExTST)))";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}