#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
"(?!.*([$]|~[^~]*~).*([$]|~[^~]*~))" & @CRLF & _
"(?!.*-.*-)" & @CRLF & _
"@[nN]([$]|~[^~]*~)?-?[1-9][0-9]*-?([$]|~[^~]*[~])?$"
Local $sString = "The following should match:" & @CRLF & _
"" & @CRLF & _
"@N$7-" & @CRLF & _
"@N-7$" & @CRLF & _
"@N$-7" & @CRLF & _
"@N7-$" & @CRLF & _
"" & @CRLF & _
"The following should not match:" & @CRLF & _
"" & @CRLF & _
"@N$5$" & @CRLF & _
"@N$-5-" & @CRLF & _
"@N-5-" & @CRLF & _
"@N7$-" & @CRLF & _
"@N-$7"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")