import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?mx)^\n"
+ "(?!.*([$]|~[^~]*~).*([$]|~[^~]*~))\n"
+ "(?!.*-.*-)\n"
+ "@[nN]([$]|~[^~]*~)?-?[1-9][0-9]*-?([$]|~[^~]*[~])?$";
final String string = "The following should match:\n\n"
+ "@N$7-\n"
+ "@N-7$\n"
+ "@N$-7\n"
+ "@N7-$\n\n"
+ "The following should not match:\n\n"
+ "@N$5$\n"
+ "@N$-5-\n"
+ "@N-5-\n"
+ "@N7$-\n"
+ "@N-$7";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}