package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mx)^
(?!.*([$]|~[^~]*~).*([$]|~[^~]*~))
(?!.*-.*-)
@[nN]([$]|~[^~]*~)?-?[1-9][0-9]*-?([$]|~[^~]*[~])?$`)
var str = `The following should match:
@N$7-
@N-7$
@N$-7
@N7-$
The following should not match:
@N$5$
@N$-5-
@N-5-
@N7$-
@N-$7`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}