re = /(?mx)^
(?!.*([$]|~[^~]*~).*([$]|~[^~]*~))
(?!.*-.*-)
@[nN]([$]|~[^~]*~)?-?[1-9][0-9]*-?([$]|~[^~]*[~])?$/
str = 'The following should match:
@N$7-
@N-7$
@N$-7
@N7-$
The following should not match:
@N$5$
@N$-5-
@N-5-
@N7$-
@N-$7'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end