$re = '/(?mx)^
(?!.*([$]|~[^~]*~).*([$]|~[^~]*~))
(?!.*-.*-)
@[nN]([$]|~[^~]*~)?-?[1-9][0-9]*-?([$]|~[^~]*[~])?$/';
$str = 'The following should match:
@N$7-
@N-7$
@N$-7
@N7-$
The following should not match:
@N$5$
@N$-5-
@N-5-
@N7$-
@N-$7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);