#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(prosjekttittel).*?\](?:[\s|\r|\n| ])+(.*)(?:[\s|\r|\n| ])+"
Local $sString = "Mal for entype-søknad (nytt søknadsformat) " & @CRLF & _
"" & @CRLF & _
"Prosjektinformasjon" & @CRLF & _
"Tittel" & @CRLF & _
"Norsk prosjekttittel (offentliggjøres) [100 tegn]" & @CRLF & _
"" & @CRLF & _
"En tittel" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Engelsk prosjekttittel (offentliggjøres) [100 tegn]" & @CRLF & _
"" & @CRLF & _
"Some title" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Velg fagkode for prosjektet" & @CRLF & _
"Her skal du velge mellom en og fem fagkoder som passer for prosjektet. En fagkode er en måte vi klassifiserer forskning på i Norge. Vi bruker dette til statistikk og analyse. Bruk fagkodene som er nærmest mulig fagfeltet for prosjektet ditt." & @CRLF & _
"[Velg fagkoder i portalen, skriv deretter inn i tabellen under]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")