using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(prosjekttittel).*?\](?:[\s|\r|\n| ])+(.*)(?:[\s|\r|\n| ])+";
string input = @"Mal for entype-søknad (nytt søknadsformat)
Prosjektinformasjon
Tittel
Norsk prosjekttittel (offentliggjøres) [100 tegn]
En tittel
Engelsk prosjekttittel (offentliggjøres) [100 tegn]
Some title
Velg fagkode for prosjektet
Her skal du velge mellom en og fem fagkoder som passer for prosjektet. En fagkode er en måte vi klassifiserer forskning på i Norge. Vi bruker dette til statistikk og analyse. Bruk fagkodene som er nærmest mulig fagfeltet for prosjektet ditt.
[Velg fagkoder i portalen, skriv deretter inn i tabellen under]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}