use strict;
my $str = 'Mal for entype-søknad (nytt søknadsformat)
Prosjektinformasjon
Tittel
Norsk prosjekttittel (offentliggjøres) [100 tegn]
En tittel
Engelsk prosjekttittel (offentliggjøres) [100 tegn]
Some title
Velg fagkode for prosjektet
Her skal du velge mellom en og fem fagkoder som passer for prosjektet. En fagkode er en måte vi klassifiserer forskning på i Norge. Vi bruker dette til statistikk og analyse. Bruk fagkodene som er nærmest mulig fagfeltet for prosjektet ditt.
[Velg fagkoder i portalen, skriv deretter inn i tabellen under]';
my $regex = qr/(prosjekttittel).*?\](?:[\s|\r|\n| ])+(.*)(?:[\s|\r|\n| ])+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}