$re = '/(prosjekttittel).*?\](?:[\s|\r|\n| ])+(.*)(?:[\s|\r|\n| ])+/m';
$str = 'Mal for entype-søknad (nytt søknadsformat)
Prosjektinformasjon
Tittel
Norsk prosjekttittel (offentliggjøres) [100 tegn]
En tittel
Engelsk prosjekttittel (offentliggjøres) [100 tegn]
Some title
Velg fagkode for prosjektet
Her skal du velge mellom en og fem fagkoder som passer for prosjektet. En fagkode er en måte vi klassifiserer forskning på i Norge. Vi bruker dette til statistikk og analyse. Bruk fagkodene som er nærmest mulig fagfeltet for prosjektet ditt.
[Velg fagkoder i portalen, skriv deretter inn i tabellen under]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);