// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(prosjekttittel).*?\](?:[\s|\r|\n| ])+(.*)(?:[\s|\r|\n| ])+").unwrap();
let string = "Mal for entype-søknad (nytt søknadsformat)
Prosjektinformasjon
Tittel
Norsk prosjekttittel (offentliggjøres) [100 tegn]
En tittel
Engelsk prosjekttittel (offentliggjøres) [100 tegn]
Some title
Velg fagkode for prosjektet
Her skal du velge mellom en og fem fagkoder som passer for prosjektet. En fagkode er en måte vi klassifiserer forskning på i Norge. Vi bruker dette til statistikk og analyse. Bruk fagkodene som er nærmest mulig fagfeltet for prosjektet ditt.
[Velg fagkoder i portalen, skriv deretter inn i tabellen under]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}