using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"https?:\/\/(?:www.)?instagram.com\/reel\/([^\/?#&]+).*";
        string input = @"https://www.instagram.com/reel/COKwCmxF5rg/?utm_medium=copy_link
https://www.instagram.com/reel/CPmmgosDt5P/?utm_medium=copy_link
https://www.instagram.com/reel/CP3XqlLFnVp/?utm_medium=copy_link
https://www.instagram.com/reel/CQGlAPyoJJQ/?utm_medium=copy_link
https://www.instagram.com/reel/CPvQ3byFP0n/?utm_medium=copy_link
https://www.instagram.com/reel/CQAzj4xjERd/?utm_medium=copy_link
https://www.instagram.com/reel/CQREuNLnk4h/?utm_medium=copy_link
https://www.instagram.com/reel/CPxOWAJATxZ/?utm_medium=copy_link
https://www.instagram.com/reel/CPv2e1ej7Sq/?utm_medium=copy_link
https://www.instagram.com/reel/CP4fkUoBY9q/?utm_medium=copy_link
https://www.instagram.com/reel/CQL2EcVHtMz/?utm_medium=copy_link
";
        RegexOptions options = RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}