import Foundation
let pattern = ##"https?:\/\/(?:www.)?instagram.com\/reel\/([^\/?#&]+).*"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www.instagram.com/reel/COKwCmxF5rg/?utm_medium=copy_link
https://www.instagram.com/reel/CPmmgosDt5P/?utm_medium=copy_link
https://www.instagram.com/reel/CP3XqlLFnVp/?utm_medium=copy_link
https://www.instagram.com/reel/CQGlAPyoJJQ/?utm_medium=copy_link
https://www.instagram.com/reel/CPvQ3byFP0n/?utm_medium=copy_link
https://www.instagram.com/reel/CQAzj4xjERd/?utm_medium=copy_link
https://www.instagram.com/reel/CQREuNLnk4h/?utm_medium=copy_link
https://www.instagram.com/reel/CPxOWAJATxZ/?utm_medium=copy_link
https://www.instagram.com/reel/CPv2e1ej7Sq/?utm_medium=copy_link
https://www.instagram.com/reel/CP4fkUoBY9q/?utm_medium=copy_link
https://www.instagram.com/reel/CQL2EcVHtMz/?utm_medium=copy_link
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)