# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"https?:\/\/(?:www.)?instagram.com\/reel\/([^\/?#&]+).*"
test_str = ("https://www.instagram.com/reel/COKwCmxF5rg/?utm_medium=copy_link\n"
"https://www.instagram.com/reel/CPmmgosDt5P/?utm_medium=copy_link\n"
"https://www.instagram.com/reel/CP3XqlLFnVp/?utm_medium=copy_link\n"
"https://www.instagram.com/reel/CQGlAPyoJJQ/?utm_medium=copy_link\n"
"https://www.instagram.com/reel/CPvQ3byFP0n/?utm_medium=copy_link\n"
"https://www.instagram.com/reel/CQAzj4xjERd/?utm_medium=copy_link\n"
"https://www.instagram.com/reel/CQREuNLnk4h/?utm_medium=copy_link\n"
"https://www.instagram.com/reel/CPxOWAJATxZ/?utm_medium=copy_link\n"
"https://www.instagram.com/reel/CPv2e1ej7Sq/?utm_medium=copy_link\n"
"https://www.instagram.com/reel/CP4fkUoBY9q/?utm_medium=copy_link\n"
"https://www.instagram.com/reel/CQL2EcVHtMz/?utm_medium=copy_link\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.