// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https?:\/\/(?:www.)?instagram.com\/reel\/([^\/?#&]+).*").unwrap();
let string = "https://www.instagram.com/reel/COKwCmxF5rg/?utm_medium=copy_link
https://www.instagram.com/reel/CPmmgosDt5P/?utm_medium=copy_link
https://www.instagram.com/reel/CP3XqlLFnVp/?utm_medium=copy_link
https://www.instagram.com/reel/CQGlAPyoJJQ/?utm_medium=copy_link
https://www.instagram.com/reel/CPvQ3byFP0n/?utm_medium=copy_link
https://www.instagram.com/reel/CQAzj4xjERd/?utm_medium=copy_link
https://www.instagram.com/reel/CQREuNLnk4h/?utm_medium=copy_link
https://www.instagram.com/reel/CPxOWAJATxZ/?utm_medium=copy_link
https://www.instagram.com/reel/CPv2e1ej7Sq/?utm_medium=copy_link
https://www.instagram.com/reel/CP4fkUoBY9q/?utm_medium=copy_link
https://www.instagram.com/reel/CQL2EcVHtMz/?utm_medium=copy_link
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}