const regex = /https?:\/\/(?:www.)?instagram.com\/reel\/([^\/?#&]+).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/(?:www.)?instagram.com\\\/reel\\\/([^\\\/?#&]+).*', 'gm')
const str = `https://www.instagram.com/reel/COKwCmxF5rg/?utm_medium=copy_link
https://www.instagram.com/reel/CPmmgosDt5P/?utm_medium=copy_link
https://www.instagram.com/reel/CP3XqlLFnVp/?utm_medium=copy_link
https://www.instagram.com/reel/CQGlAPyoJJQ/?utm_medium=copy_link
https://www.instagram.com/reel/CPvQ3byFP0n/?utm_medium=copy_link
https://www.instagram.com/reel/CQAzj4xjERd/?utm_medium=copy_link
https://www.instagram.com/reel/CQREuNLnk4h/?utm_medium=copy_link
https://www.instagram.com/reel/CPxOWAJATxZ/?utm_medium=copy_link
https://www.instagram.com/reel/CPv2e1ej7Sq/?utm_medium=copy_link
https://www.instagram.com/reel/CP4fkUoBY9q/?utm_medium=copy_link
https://www.instagram.com/reel/CQL2EcVHtMz/?utm_medium=copy_link
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}