using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"index=""(?P<index_ks>.*)"";";
string input = @" 2017-09-10 23:55:12,457 INFO device=""PERIMETA-IMSSSC01HAM"",index=""P-CSCF-load.register.summaryPeriod1CurrentClctnIntv""; adjMthdStatISASentCount=""0"", adjMthdStatISARcvdCount=""0"", adjMthdStatESERcvdCount=""0"", adjMthdStatESESentCount=""0""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}