// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"index="(?P<index_ks>.*)";"#).unwrap();
let string = " 2017-09-10 23:55:12,457 INFO device=\"PERIMETA-IMSSSC01HAM\",index=\"P-CSCF-load.register.summaryPeriod1CurrentClctnIntv\"; adjMthdStatISASentCount=\"0\", adjMthdStatISARcvdCount=\"0\", adjMthdStatESERcvdCount=\"0\", adjMthdStatESESentCount=\"0\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}