use strict;
my $str = ' 2017-09-10 23:55:12,457 INFO device="PERIMETA-IMSSSC01HAM",index="P-CSCF-load.register.summaryPeriod1CurrentClctnIntv"; adjMthdStatISASentCount="0", adjMthdStatISARcvdCount="0", adjMthdStatESERcvdCount="0", adjMthdStatESESentCount="0"';
my $regex = qr/index="(?P<index_ks>.*)";/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}