const regex = /index="(?P<index_ks>.*)";/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('index="(?P<index_ks>.*)";', 'g')
const str = ` 2017-09-10 23:55:12,457 INFO device="PERIMETA-IMSSSC01HAM",index="P-CSCF-load.register.summaryPeriod1CurrentClctnIntv"; adjMthdStatISASentCount="0", adjMthdStatISARcvdCount="0", adjMthdStatESERcvdCount="0", adjMthdStatESESentCount="0"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}