$re = '/index="(?P<index_ks>.*)";/';
$str = ' 2017-09-10 23:55:12,457 INFO device="PERIMETA-IMSSSC01HAM",index="P-CSCF-load.register.summaryPeriod1CurrentClctnIntv"; adjMthdStatISASentCount="0", adjMthdStatISARcvdCount="0", adjMthdStatESERcvdCount="0", adjMthdStatESESentCount="0"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);